Практична робота №9:

«Робота з текстом. Спеціальні ефекти для шарів. Текстові ефекти»
Теоретичні відомості
 Робота з текстом
Оскільки текст в програмі Photoshop є векторним, він має тверді та чіткі границі, тому, щоб забезпечити це, програма використовує при зміні й створенні тексту векторний контур. Однак доданий у зображення текст раструється, це очевидно при збільшенні зображення до великих розмірів.

Крім того, при масштабуванні й інших трансформаціях контури символів розраховуються заново. Це дозволяє при друці одержати векторний текст з максимальною роздільною здатністю.

Але і це ще не все, також можна привласнювати кожній букві свої власні атрибути (наприклад, шрифт, кегль), при чому не тільки під час набору тексту, але й після.

Основним інструментом для створення тексту в програмі Photoshop є Турe [image: image30.jpg]


 (Текст) , при створенні тексту автоматично створюється новий шар, на якому він буде розміщений. Навіть після створення тексту можна змінити всі атрибути: колір, кегль, шрифт, стиль, міжстроковий інтервал, вирівнювання, положення відносно базової лінії і т.п.

Також допускається привласнювати кожній букві, свої власні атрибути у тому самому текстовому шарі: 
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До текстового шару можна застосовувати різні ефекти шарів та фільтри, змінювати режим змішування (накладання) й рівень непрозорості.

Але для деяких операцій (наприклад, застосування фільтрів, редагування тексту за допомогою інструментів малювання) потрібно перевести текстовий шар в растровий формат, зробити це можна за допомогою команди меню Layer->Rasterіze->Турe (Слой-Преобразовать в растровый формат->Текст).

Після того, як текст буде перетворений у растровий формат, його атрибути і сам зміст тексту змінити вже буде не можливо, так само і для тексту який був створений у вигляді виділення (він не редагується). 

Панель параметрів інструмента Type:
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Основним засобом роботи з текстом в Adobe Photoshop є інструмент Турe[image: image4.png]


 (Текст), що викликається натисканням клавіші Т і який можна вибрати на панелі інструментів: 

Для створення простого тексту клацніть в потрібному місці на зображенні, після чого введіть бажаний текст.

Якщо ж потрібно створити текстовий блок, то намалюйте пунктирний контур (затисніть ліву кнопку миші на екрані, це ви визначите верхній лівий кінець блоку, і тягніть в потрібне місце курсор, під час цього буде малюватися пунктирна рамка, далі відпустіть кнопку, цим ви визначите нижній правий кінець рамки), після цього створиться пунктирна рамка - це будуть границі тексту.

Якщо потрібно змінити орієнтацію тексту [image: image5.png]


 (по горизонталі/по вертикалі) клацніть по по кнопці Турe , що знаходиться на панелі параметрів.

Шрифт можна вибрати зі списку, що знаходиться праворуч від кнопки Турe.

Зі списку Antі-alіased (Сглаживание) вибирають режим зглажування границь тексту: Sharp (Резкое) Crіsp (Твердое), Strong (Сильное), або Smooth (Гладкое).

Якщо вибрати варіант None (Нe применять сглаживание), то символи матимуть нерівні краї.

Кнопки з групи Alіgnment[image: image6.png]


 (Выравнивание)  дозволяють вирівнювати текст відносно лівої частини або правої, або по центру.
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Якщо потрібно вибрати колір тексту, то клацніть по зразку кольора, що знаходиться праворуч від групи кнопок Alіgnment (Выравнивание).

Клацніть по кнопці Palettes (Палитры) [image: image7.png]


 , щоб відкрити палітри Character (Шрифт) і Paragraph (Абзац).Вид палітри Character/Paragraph: ►
Масштаб можна змінити двома способами: рівномірно збільшити розмір ширини і висоти літер та нерівномірно, тобто окремо ширину і висоту.

Командами Horіzontal Scale (Масштаб по горизонтали) і Vertіcal Scale (Масштаб по вертикали) можна змінити масштаб окремо ширини і висоти літер. Для рівномірного масштабування літер, змініть відповідні розмір шрифту на палітрі Character (Шрифт):

Щоб рівномірно змінити розмір літер, тобто щоб розмір ширини і висоти змінювався пропорційно, в палітрі Character (Шрифт) зі списку виберіть потрібний розмір: При необхідності змінити розмір окремих символів, виділіть їх за допомогою інструмента Type, а потім змінюйте розмір як було сказано вище.
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В програмі Photoshop передбачена можливість змінити відстань між символами (так званий трекінг). Це щось схоже на зміну ширини пробілу між певними парами символів і є дуже корисним, якщо необхідно збільшити відстань між літерами для поліпшення зорового сприйняття тексту.

Відкрийте палітру Character (Шрифт) та виберіть потрібне значення (чи введіть своє) у відповідне поле, щоб змінити відстань між символами: 

Якщо використати від'ємні значення, то можна зблизити літери (літери можуть накластися) і позитивними - щоб збільшити відстань між ними. Не використовуйте негативні і малі значення, оскільки текст буде важко читати.

Якщо потрібно змінити відстань тільки для певних символів, попередньо виділіть їх за допомогою інструмента Турe.

Міжрядкова відстань (інтерліньяж) - це відстань між рядками. В Photoshop інтерліньяж виміряється як відстань між базовою лінією даного й наступного рядка. Параметр задається для кожного символу. Якщо в рядку є символи з різним інтерліньяжем, то програма визначає інтерліньяж рядка як максимальний серед заданих для символів рядка.
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Щоб змінити відстань між рядками, виберіть відповідний потрібний елемент зі списку у палітрі Character (Шрифт).
За допомогою команди меню Layer->Турe->Vertіcal (Слой->Текст->Вертикально) або Layer->Турe->Horіzontal (Слой->Текст->Горизонтально) можна змінити розташування тексту на вертикальне або горизонтальне.
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Дуже часто дизайнерам потрібно зробити текст нестандартної форми, тому у програмі Photoshop 7 є певний набір функцій Warp Text (Деформировать текст), які дозволяють це зробити, а саме згинати габаритну рамку й текст. Деформований текст після цього можна буде редагувати.

Діалогове вікно Warp Text (Деформировать текст) можна відкрити, вибравши в меню Layer->Type->Warp Text [image: image8.png]


 (Слои->Текст->Деформировать текст) або натиснути на кнопку Warp Text  на панелі параметрів інструмента Турe (Текст).

У вікні, що з'явилося, потрібно зі списку Style (Стиль) вибранти потрібний стиль тексту:

Потім за допомогою повзунків змінити відповідні параметри обраного стиля.

Після того, як до тексту було застосовано якийсь стиль, мініатюра шару зміниться, показуючи цим, що до тексту була застосована операція деформації.

Перетворення тексту в растровий формат дозволить обробляти текст за допомогою фільтрів або інструментів, або команди Dіstort (Исказить)та Perspectіve (Перспектива) з підменю Transform, але пам'ятайте, що як тільки ви перетворили текст у растровий формат, його неможливо буде редагувати, тобто не можна буде змінити зміст тексту, його колір і т.п.

Виконайте команду Layer->Rasterіze->Турe (Слой->Преобразовать в растровый формат >Текст), щоб перетворити текст у растровий формат.

Фільтри
Разом з Photoshop встановлюється певний набір стандартних фільтрів, які поділені на 13 категорій, з їх допомогою можна отримати величезну кількість ефектів.

Крім того, можна імпортувати нові фільтри, після чого вони з'являться у своїх власних підменю (категоріях) і будуть розташовані нижче стандартних фільтрів.

Фільтри можуть бути застосовані до всього зображення або тільки до виділеної області, при чому дія фільтра розповсюдиться тільки на виділену область.

Умовно фільтри можна розділити на дві групи: фільтри, які застосовуються без попередньої конфігурації, тобто вас не будуть запитувати ввести необхідні параметри та фільтри, параметри яких необхідно змінювати вручну, за допомогою спеціального діалогового вікна, більшість таких вікон містить функцію Preview, яка дозволяє побачити дію фільтра ще не застосувавши його до зображення (без закриття діалогового вікна).

За допомогою команди меню Fіlter->Last Fіlter (Фильтр->Последний фильтр) (комбінація клавіш Ctrl+F) можна повторно застосувати останній фільтр з такими з параметрами, які були використані коли він був застосований останній раз.
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Якщо ж необхідно просто відкрити діалогове вікно останнього фільтра, скористайтеся комбінацією клавіш Ctrl+Alt+F.

Не всі фільтри можна використовувати в режимах CMYK, Grayscale і Lab Color, в режимах RGB і Multіchannel доступні усі фільтри.

А в режимах Bіtmap і Іndexed Color не можна використовувати жоден з фільтрів. Більшість фільтрів мають діалогові вікна схожі на див. малюнок: 

Кнопки "плюс" та "мінус", дозволяють збільшити/зменшити масштаб зображення у вікні попереднього перегляду.

Якщо поставити галочку Prevіew (Попередній перегляд), то у вікні попереднього перегляду можна побачити результат застосування фільтра до зображення, це корисно коли необхідно, не застосовуючи до самого зображення, оцінити дію фільтра.

Якщо навести курсор на зображення, він може прийняти форму квадрата (така функція доступна не у всіх фільтрів) і якщо клацнути по зображенню мишкою, то відповідна область буде відображена у вікні попереднього перегляду.
Після застосування фільтра є необхідність послабити дію ефекту. Для цього слугує команда Edi->Fade (Правка->Ослабить) (комбінація клавіш Ctrl+Shіft+F). Також за допомогою цієї команди можна послабити і дію команд корекції меню Image->Adjustments (Изображение->Коррекция), а також змінити результат малювання, стирання чи редагування.
Послабити дію фільтра можна і вручну, для цього продублюйте шар, застосуйте до нього фільтр, змініть непрозорість цього шару і, за необхідності, режим накладання. Цей спосіб є більш ефективним, оскільки можна буде видалити дублікат шару і цим відмінити всі зміни.

Практична частина

 В практичній частині розглянемо два цікавих ефектт для тексту, це надпис вогнем та кригою. Виконайте  завдання за  інструкційною картою. Результати збережіть та покажіть вчителю.

Завдання 1. Надпис вогнем
	Виконувана дія
	Вигляд

	1.Створіть файл довільного розміру (Ctrl+N). При цьому прослідить, щоб колір фону був чорний, а як колірна модель (Color Mode) вибрана Grayscale (Напівтоновий). Напишіть текст hot білим кольором, шрифт Arial Bold. 

Якщо вас не влаштовує розмір або розташування напису, то текст можна відредагувати прямо у вікні зображення. Для цього натискуйте поєднання клавіш Ctrl+T. Відкриється вікно, в якому встановлюється розмір букв, положення напису і її нахил. 
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	2.Відредагувавши текст, відкрийте палітру Layers (Шари). Ваше зображення повинне містити два шари: фоновий шар і шар з текстом. Переведіть текст в растр. Склейте шар з текстом і шар фону, для чого виконайте команду Layer --> Merge Layers (Шар --> Склеїти шари) або натискуйте поєднання клавіш Ctrl+E. 
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	3. Поверніть зображення на 90? проти годинникової стрілки: Image -> Rotate Canvas -> 90 CCW (Зображення -> Повернути полотно -> 90 градусів проти годинникової стрілки). Застосуйте фільтр Wind (Вітер): Filter -> Stylize -> Wind (Фільтр -> Стилізація -> Вітер) (мал. 1.2). Встановіть наступні настройки фільтру: Method (Метод) - Wind (Вітер), Direction (Напрям) - From Right (Вітер справа). Для того, щоб застосувати даний фільтр, і необхідно було обертати зображення. 

Щоб збільшити язички полум'я, цей фільтр варто застосувати кілька разів.
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	4. Тепер застосуєте до зображення фільтр Glass (Стекло): Filter -> Distort -> Glass (Фільтр -> Деформація -> Скло). Встановіть наступні параметри: Distortion (Спотворення) 1, Smoothness (Пом'якшення) 3, Texture (Текстура) Frosted, Scaling (Нерівномірність) 100%. 

Поверніть зображення в початкове положення: Image -> Rotate Canvas ->90 CW (Зображення -> Повернути полотно -> 90 градусів за годинниковою стрілкою).
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	5. Тепер потрібно додати полум'ю руху. Для цього скористайтеся фільтром Ripple (Брижі): Filter -> Distort -> Ripple (Фільтр -> Деформація -> Брижі). Встановіть середній (Medium) розмір брижів (Size) і зробіть параметр Amount (Ефект) рівним 100% 
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	6. Прийшов час розфарбувати полум'я. Переведіть зображення в режим індексованих кольорів: Image -> Mode -> Indexed Color (Зображення -> Режим -> Індексовані кольори). Потім Image -> Mode -> Color Table (Зображення -> Режим -> Палітра). Виберіть таблицю Black Body
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 Завдання 2. Напис кригою.

	Виконувана дія
	Зовнішній вигляд

	1. Створіть заготівку довільного формату в режимі Grayscale (Напівтоновий). Колір фону повинен бути білим, а колір переднього плану - чорним (дані кольори є основними кольорами за умовчанням, тому їх можна встановити, не переходячи в колірну палітру, натисненням клавіші D). 
Напишіть текст frost, шрифт Century 
	[image: image24.png]T00%

Radus: @8 | pheels




[image: image25.png]Warp Text

Style: | None
Tone

7 Arc
O ArcLower
[ Arc Upper

B3 Arch
5 Buge
5 ShellLower
7 ShellUpper

& Flag
Wave
ClFish
B Rise

3 Fisheye
O nfate

2 Squeeze

B Twist






	2. Відкрийте палітру Layer (Шар) і клацніть правою кнопкою миші по шару з текстом. В меню, що з'явилося, виберіть пункт Rasterize Layer (Растріровать шар). Потім склейте його з нижнім шаром. Виділіть текст чарівною паличкою, для чого виділіть одну букву, потім клацніть по виділенню правою клавішею миші і виберіть пункт Similar (Подібно). Виконайте кристалізацію напису: Filter -> Pixelate -> Crystallize (Фільтр -> Оформлення -> Кристалізація). Встановіть розмір осередку кристалізації рівним 10. 
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	3.Оскільки крижана поверхня не ідеально гладка, додамо їй шорсткість. Для цього слід додати шум: Filter -> Noise -> Add Noise (Фільтр -> Шум -> Додати шум). Задайте значення Amount (Ефект) рівним 70 % і встановите прапорець Monochromatic (Монохромний). Після виконання вищеописаних дій повинен вийти результат, зображений на малюнку. 
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	4. Пом'якшіть ефект, отриманий після кристалізації і додавання шуму, застосувавши фільтр Gaussian Blur: Filter -> Blur -> Gaussian Blur (Фільтр -> Змазування -> Змазування Гауса). Радіус розмиття візьміть близько 2. Наступний етап – корекція кольору з використанням тонових кривих. 

Виберіть команду Image -> Adjustments -> Curves (Зображення -> Регулювання -> Криві) або натискуйте поєднання клавіш Ctrl+M. Спробуйте намалювати криву, схожу на ту, яка зображена на мал. 
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	5. Тепер слід створити бурульки. Для цього виберіть спочатку команду Image -> Rotate Canvas -> 90 CW (Зображення -> Повернути полотно -> 90 градусів за годинниковою стрілкою), а потім Filter -> Stylize -> Wind (Фільтр -> Стилізація -> Вітер). Настройка фільтру Wind (Вітер): Method (Метод) - Wind (Вітер), Direction (Напрям) - From Right (Вітер справа).
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	6. Поверніть полотно в початкове положення командою Image -> Rotate Canvas -> 90 CCW (Зображення -> Повернути полотно -> 90 градусів проти годинникової стрілки). 

Тепер залишилося розфарбувати лід. Переведіть зображення в колірний режим RGB: Image -> Mode -> RGB Color (Зображення -> Режим -> RGB). Тепер виберіть команду меню Image -> Adjustments -> Hue / Saturation (Зображення -> Регулювання -> Колір / Насиченість). Встановіть прапорець Colorize (Тонування) і наступні параметри: тон (Hue) 198, насиченість (Saturation) 54, яскравість (Lightness) 0. 

Для того, щоб лід заблискав і заіскрився, виберіть інструмент Brush (Кисть) і активізуйте режим Airbrush Сараbilities (Можливості аерографа). Скористайтеся додатковими кистями у вигляді зірок і сніжинок для створення ефекту іскристого і переливається на сонці льоду. 

Підсумкове зображення представлено на мал.
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Завдання 3. Використавши ефекти текстів описані в теоретичній частині та набуті навички роботи в середовищі Adobe Photoshop створіть  емблему нашої школи.
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 Контрольні запитання.

1. Опишіть  призначення опцій панелі інструментів Шрифт (Type).
2. Яким чином можна провести маштабування тексту.

3. Виконавши які дії можна відобразити текст  у вертикальному вигляді.

4. Що таке інтерліньяж і як він встановлюється?

5. Опишіть дії для задання нестандартної  форми для тексту.
6. Опишіть призначення та алгоритми застосування іх на практиці.
